IntelliJ IDEA:使用Grails

Grails

此功能仅在Ultimate版本中受支持。

IntelliJ IDEA支持Grails 3.0(包括)以上的版本,并且支持这些版本中的所有功能。

先决条件

确保在您的计算机上下载并安装了所需的SDK,并且已正确配置库。

此外,请确保在IntelliJ IDEA中启用了Grails插件。该插件与IntelliJ IDEA捆绑在一起,默认情况下处于激活状态。如果未启用该插件,请启用该插件。

IntelliJ IDEA中的Grails功能

IntelliJ IDEA中的Grails支持包括以下功能:

  • 创建可提供特定结构和工件生成的Grails Applications的自动化方法。
  • 在Grails Applications模块中自动启用Groovy支持,允许创建Groovy类,接口和脚本。
  • 执行目标。
  • 生成脚手架的可能性。
  • 可以生成测试。
  • 代码完成。
  • 使用动态查找器查询。
  • 专用的运行/调试配置。
  • Grails 3.1.0支持GORM 5.0版。
  • Grails Web层。
  • Grails Resources插件。
  • Grails Spock。
  • Grails Standalone GORM
以上内容是否对您有帮助:
在线笔记
App下载
App下载

扫描二维码

下载编程狮App

公众号
微信公众号

编程狮公众号

意见反馈
返回顶部