IntelliJ IDEA如何构建JDK

为了能够使用 IntelliJ IDEA 编译应用程序,您需要指定一个构建 JDK。可以在项目级别上配置构建 JDK。如果您有一个复杂的项目,您可能需要为不同的模块配置不同的 JDK。

本节说明如果定义了多个JDK,IntelliJ IDEA 如何选择构建 JDK,以及如何配置它们:

IntelliJ IDEA 如何知道要使用哪个 JDK?

本节介绍如果在每个模块上配置了多个 JDK,则由 IntelliJ IDEA 选择构建 JDK 的算法。IntelliJ IDEA 执行以下操作来确定要用于编译的 JDK:

  • IntelliJ IDEA 检查项目中使用的所有 JDK(即在项目和模块级别上定义的 JDK)。
  • IntelliJ IDEA 计算最新的这些 JDK。这是必要的,以确保所有模块都可以编译。
  • 如果配置的最新 JDK 的版本低于 1.6,则将使用用于运行 IntelliJ IDEA 的 JDK 版本。此限制与以下事实有关: 从 JDK 1.6 开始,支持由 IntelliJ IDEA 用于生成项目的编译器 API。
  • 虽然将使用编译器的特定版本(根据所选的 JDK 版本),每个单独的模块将使用 javac 的交叉编译功能针对在项目设置中为此特定模块定义的 JDK 的库进行编译。这样可以防止模块针对较新的库编译而不是依赖关系设置的情况。

JDK 环境

目前大多数 IDE 都没有集成 JDK 环境,IDEA 也是一样,在使用 IDEA 之前首先要安装 JDK,并且配置环境变量。与其他 IDE 不同之处在于,IDEA 不会自动匹配系统的 JDK 环境,编译时会提示以下错误信息:

Using javac 1.7.0_40 to compile java sources
java: JPS build failed to load optimized file manager for javac:
java.lang.NoClassDefFoundError: com/sun/tools/javac/util/DefaultFileManager
java.lang.NoClassDefFoundError: com/sun/tools/javac/file/JavacFileManager
java: 致命错误: 在类路径或引导类路径中找不到程序包 java.lang
……
java: Compilation failed: internal java compiler error

IntelliJ IDEA 可以为每个项目指定不同版本的 JDK,并且需要开发者手动配置项目的所使用的 JDK 版本。配置方法如下:

  1. 单击 File | Project Structure 菜单项,打开 ProjectStructure(项目结构)对话框。
  2. 执行以下操作之一:
    • 要为整个项目设置构建 JDK,请在左窗格中选择 "项目"。在右侧的 "项目 sdk" 下,从下拉列表中选择所需的 SDK。
    • 要为特定模块设置构建 JDK,请在左窗格中选择 "模块",然后在中央窗格中选择所需的模块,然后在 "模块 SDK" 下拉列表中指定一个 JDK。 
      如果您之前没有创建任何项目并指定了 JDK 的路径,请单击 "新建",选择 JDK 并在打开的对话框中浏览 JDK 的安装文件夹。

注意,您还可以通过编辑适当的运行/调试配置来覆盖项目或模块级别的 JDK 设置,以进行特定的调试或测试。

以上内容是否对您有帮助:
在线笔记
App下载
App下载

扫描二维码

下载编程狮App

公众号
微信公众号

编程狮公众号

意见反馈
返回顶部