scrapy 2.3 PyPy环境搭建教程

2021-06-09 10:03 更新

我们建议使用最新的Pypy版本。测试版本为5.9.0。对于pypy3,只测试了Linux安装。


大多数垃圾依赖现在都有CPython的二进制轮子,但PyPy没有。这意味着这些依赖项将在安装期间生成。在macOS上,您可能会面临构建加密依赖关系的问题,本文介绍了这个问题的解决方案 here ,就是 ​brew install openssl​ 然后导出此命令建议的标志(仅在安装scray时需要)。除了安装构建依赖项之外,在Linux上安装没有特殊问题。在Windows上用PyPy安装Scrapy没有经过测试。


运行以下命令可以检查scray是否正确安装 ​scrapy bench​ . 如果此命令给出错误,例如 ​TypeError: ... got 2 unexpected keyword arguments​ ,这意味着安装工具无法获取一个Pypy特定的依赖项。要解决此问题,请运行 ​pip install 'PyPyDispatcher>=2.1.0'​ .

以上内容是否对您有帮助:
在线笔记
App下载
App下载

扫描二维码

下载编程狮App

公众号
微信公众号

编程狮公众号