scrapy 2.3 Ubuntu环境搭建教程

2021-06-01 15:57 更新

Ubuntu 14.04或以上

Scrapy目前已经用LXML、Twisted和PyOpenSSL的最新版本进行了测试,并且与最新的Ubuntu发行版兼容。但是它也应该支持Ubuntu的旧版本,比如Ubuntu14.04,尽管存在与TLS连接相关的潜在问题。

Don't 使用 ​​python-scrapy​​ Ubuntu提供的软件包,它们通常太旧,速度太慢,赶不上最新的垃圾。

要在Ubuntu(或基于Ubuntu的)系统上安装scray,需要安装以下依赖项:

sudo apt-get install python3 python3-dev python3-pip libxml2-dev libxslt1-dev zlib1g-dev libffi-dev libssl-dev
  • ​​python3-dev​​, ​​zlib1g-dev​​, ​​libxml2-dev​​ and ​​libxslt1-dev​​ are required for ​​lxml​
  • ​libssl-dev​​ and ​​libffi-dev​​ are required for ​​cryptography​​

在a:ref: ' virtualenv < introduction - use -virtualenv> '内部,您可以在后面安装带有' ' pip ' '的Scrapy:

pip install scrapy

注解

相同的非python依赖项可用于在debian jessie(8.0)及更高版本中安装scrapy。

以上内容是否对您有帮助:
在线笔记
App下载
App下载

扫描二维码

下载编程狮App

公众号
微信公众号

编程狮公众号