scrapy 2.3 macOS环境搭建教程

2021-06-09 10:03 更新

macOS

构建Scrapy的依赖项需要有一个C编译器和开发头文件。在macOS上,这通常是由苹果的Xcode开发工具提供的。要安装Xcode命令行工具,请打开终端窗口并运行:

xcode-select --install

有一个“已知问题<https: github.com="" pypa="" pip="" issues="" 2468="">”_阻止“' pip '”更新系统包。</https:>要成功安装Scrapy及其依赖项,必须解决这个问题。以下是一些建议的解决方案:

  • (推荐) Don't 使用系统python,安装一个新的、更新的版本,它不会与系统的其他部分冲突。以下是如何使用 homebrew 包管理器:
  • 安装 homebrew 遵循https://brew.sh中的说明/
  • 更新你的 ​PATH​ 变量,说明应在系统包之前使用自制包(更改 ​.bashrc​ 到 ​.zshrc​ 如果你在使用  zsh 作为默认外壳):​
  • echo "export PATH=/usr/local/bin:/usr/local/sbin:$PATH" >> ~/.bashrc
  • 重新加载``.bashrc``以确保发生了变化:
  • source ~/.bashrc
  • 安装python:
  • brew install python
  • 最新版本的python ​pip​ 与它们捆绑在一起,这样您就不需要单独安装。如果不是这样,请升级python:
  • brew update; brew upgrade python
  • (可选) Install Scrapy inside a Python virtual environment .
此方法是解决上述macOS问题的一种解决方法,但它是管理依赖关系的一种总体良好实践,可以补充第一种方法。

在任何这些解决方法之后,您都应该能够安装scrapy::

pip install Scrapy


以上内容是否对您有帮助:
在线笔记
App下载
App下载

扫描二维码

下载编程狮App

公众号
微信公众号

编程狮公众号