安装

安装 Composer

Laravel 框架使用 Composer 来管理其依赖性。所以,在你使用 Laravel 之前,你必须确认在你电脑上是否安装了 Composer。

安装 Laravel

通过 Laravel 安装工具

首先,使用 Composer 下载 Laravel 安装包:

composer global require "laravel/installer=~1.1"

请确定把 ~/.composer/vendor/bin 路径放置于您的 PATH 里, 这样 laravel 执行文件就会存在你的系统。

一旦安装完成后,就可以使用 laravel new 命令建立一份全新安装的 Laravel 应用,例如: laravel new blog 将会在当前目录下建立一个名为 blog 的目录, 此目录里面存放着全新安装的 Laravel 相关代码,此方法跟其他方法不一样的地方在于会提前安装好所有相关代码,不需要再通过 composer install 安装相关依赖,速度会快许多。

laravel new blog

通过 Composer Create-Project

你一样可以通过 Composer 在命令行执行 create-project 来安装 Laravel:

composer create-project laravel/laravel --prefer-dist

脚手架

Laravel 自带了用户注册和认证的脚手架。如果你想要移除这个脚手架,使用 fresh 命令即可:
php artisan fresh

环境需求

Laravel 框架有一些系统上的需求:

  1. PHP 版本 >= 5.4
  2. Mcrypt PHP 扩展
  3. OpenSSL PHP 扩展
  4. Mbstring PHP 扩展
  5. Tokenizer PHP 扩展

在 PHP 5.5 之后, 有些操作系统需要手动安装 PHP JSON 扩展包。如果你是使用 Ubuntu,可以通过 apt-get install php5-json 来进行安装。

以上内容是否对您有帮助:
在线笔记
App下载
App下载

扫描二维码

下载编程狮App

公众号
微信公众号

编程狮公众号

意见反馈
返回顶部