Windows 开发下Android环境配置

由 卓别林 创建, 最后一次修改 2016-08-27

1.以下移植android的环境配置所需的工具:

ADT(eclipse+androidSDK)

http://pan.baidu.com/s/1dDnvbjj


androidNDK(推荐android-ndk-r9c)

http://pan.baidu.com/s/1o6KmBmq


JDK(jdk-7u45-windows-x64)

http://pan.baidu.com/s/1sj8BgNr


以上列出的工具也可以使用其他的版本,NDK的要求r8以上版本,配置的方法基本一样,请根据操作系统型号选择配置环境所需的工具包。


2.安装java环境

配置Android环境必须要先安装java环境,安装的过程没有什么特别要求。

安装完成后需要配置环境变量,在Windows系统变量中新建一个变量名为 JAVA_HOME 的变量,变量值为jdk的安装目录。例如:C:Program FilesJavajdk1.7.0_45。

再新建一个名为 CLASSPATH 的变量,变量的值为:.;%JAVA_HOME%lib;%JAVA_HOME%libtools.jar (最前面的.;一定要加上),在系统变量中找到 Path 变量,点击编辑,在变量值最前面添加一个分号,然后在分号的前面添加 %JAVA_HOME%bin;%JAVA_HOME%jrebin 这样java的环境变量已经配置好了,打开dos,输入java、javac、java –version等命令就能看见相关的信息。


3.移植Android

将工程导入eclipse,File->New->Other->Android Project from Existing Code,点击 Browse 找到我们引擎目录下 CrossApp 里的 proj.android

如图:

移植Android


将工程导入eclipse,File->New->Other->Android Project from Existing Code,点击 Browse 找到我们新创建的工程目录下的 proj.android

如图:

将工程导入eclipse


4.导入完成后需要确认以下配置:

1)确认Android 版本和引擎版本一致

确认Android 版本和引擎版本一致

如图中 Android 版本都为 4.4.2,如果不一样右键引擎选择 Properties->Android 选择和新建项目版本一样的 Android版本。

2)更改新建项目的ndk路径为ndk的根目录。例如:D:androidandorid-ndk-r9

更改新建项目的ndk路径为ndk的根目录

例如:D:androidandroid-ndk-r9c


3)在新建项目中找到 jni 目录下的 Android.mk 文件找到如下代码:

#$(call import-add-path, $(LOCAL_PATH)/../../../..)
#$(call import-add-path, $(LOCAL_PATH)/../../../../CrossApp/the_third_party/)

找到后把代码前的#号删除。找到后把代码前的#号删除。


5.以上步骤完成后,我们直接右键工程->Run As Android Application,开始编译我们的工程。


6.工程导入eclipse后,编译运行过程中所出现的异常和错误以及对应的解决办法如下表所示。

错误
解决办法
在工程src下的包错误,提示找不到org.CrossApp.lib这个包将工程导入eclipse,File->New->Other->Android Project from Existing Code,点击 Browse 找到我们引擎目录下 CrossApp 里的 proj.android。
运行工程出现Error: Program "bash" is not found in PATH右键工程->Properties,在打开面板中点击C/C++ Build,在Build command一项中,把默认的command替换为自己ndk目录下的ndk-build.cmd,例如:D:android-ndk-r9cndk-build.cmd。
运行工程出现Cannot find module with tag 'CrossApp' in import path

在新建项目中找到 jni 文件夹下的 android.mk 中找到$(call import-module,CrossApp),在这句前面添加如下两段代码:

$(call import-add-path, $(LOCAL_PATH)/../../../..)

$(call import-add-path, $(LOCAL_PATH)/../../../../CrossApp/the_third_party/)

路径修改为自己的对应路径。

模拟器运行崩溃android模拟器从sdk 4.0.3开始才支持OpenGL ES2.0,新建的模拟器的sdk也要求4.0.3及以上(建议真机看运行效果)。


7.环境配置参考视频



以上内容是否对您有帮助:
二维码
建议反馈
二维码