Flask 环境

Flask安装条件

安装Flask通常需要Python 2.6或更高版本。虽然Flask及其依赖项适用于Python 3(Python 3.3以上版本),但是许多Flask扩展不能正确支持它。因此,建议在Python 2.7上安装Flask。

为开发环境安装virtualenv

virtualenv是一个虚拟的Python环境构建器。它可以帮助用户并行创建多个Python环境。 因此,它可以避免不同版本的库之间的兼容性问题。

以下命令用于安装virtualenv:

pip install virtualenv

此命令需要管理员权限。您可以在Linux / Mac OS上的 pip 之前添加 sudo 如果您使用的是Windows,请以管理员身份登录。在Ubuntu上, virtualenv可以使用它的包管理器安装。

Sudo apt-get install virtualenv

安装后,将在文件夹中创建新的虚拟环境。

mkdir newproj
cd newproj
virtualenv venv

要在 Linux / OS X 上激活相应的环境,请使用以下命令:

venv/bin/activate

要在 Windows 上激活相应的环境,可以使用以下命令:

venv\scripts\activate

我们现在准备在这个环境中安装Flask:

pip install Flask

上述命令可以直接运行,不需要系统范围安装的虚拟环境。


以上内容是否对您有帮助:
在线笔记
App下载
App下载

扫描二维码

下载编程狮App

公众号
微信公众号

编程狮公众号

意见反馈
返回顶部