Ubuntu Docker 安装

Docker 支持以下的 Ubuntu 版本:

  • Ubuntu Precise 12.04 (LTS)
  • Ubuntu Trusty 14.04 (LTS)
  • Ubuntu Wily 15.10
  • 其他更新的版本……


前提条件

Docker 要求 Ubuntu 系统的内核版本高于 3.10 ,查看本页面的前提条件来验证你的 Ubuntu 版本是否支持 Docker。

通过 uname -r 命令查看你当前的内核版本

w3cschool@w3cschool:~$ uname -r



使用脚本安装 Docker

1、获取最新版本的 Docker 安装包

w3cschool@w3cschool:~$ sudo apt-get update


w3cschool@w3cschool:~$ sudo apt-get install -y docker.io


2、启动docker 后台服务

w3cschool@w3cschool:~$ sudo service docker start