尚学堂

Less 浏览器支持

我要纠错

LESS是跨浏览器友好的,支持诸如Google Chrome,Mozilla Firefox,Safari和Internet Explorer等现代浏览器,并允许重用CSS元素并使用相同的语义编写LESS代码。 在客户端使用LESS时,必须小心性能影响,如果存在外观问题(意味着拼写错误,颜色更改,纹理,外观,链接等),则显示JavaScript。 编译服务器端的LESS文件,为网站提供更多性能。


PhantomJS不实现 Function.prototype.bind 函数,因此您需要使用 es-5 shim JavaScript引擎在PhantomJS下运行。 用户可以使用变量进行调整以影响主题,并通过在生产中使用客户端LESS实时显示它们。


如果您想在旧版浏览器中运行LESS,请使用添加了LESS支持的JavaScript功能的 es-5 shim JavaScript引擎。 您可以使用浏览器必须支持的 JSON.parse ,在脚本或链接标签上使用属性。


二维码
建议反馈
二维码